What’s Vulnerable › Vulnerabilities
CVE-2023-31143: Mage terminal user authentication not working properly
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-09 · updated 2026-06-17
- Weakness: CWE-306
Description
mage-ai is an open-source data pipeline tool for transforming and integrating data. Those who use Mage starting in version 0.8.34 and prior to 0.8.72 with user authentication enabled may be affected by a vulnerability. The terminal could be accessed by users who are not signed in or do not have editor permissions. Version 0.8.72 contains a fix for this issue.
Affected products
- mage-ai: from 0.8.34 before 0.8.72 — fixed in 0.8.72
How to fix
Upgrade to a fixed version: mage-ai 0.8.72. Check the vendor advisory for mitigations.
References
- https://github.com/mage-ai/mage-ai/commit/f63cd00f6a3be372397d37a4c9a49bfaf50d7650
- https://github.com/mage-ai/mage-ai/security/advisories/GHSA-c6mm-2g84-v4m7
- https://github.com/mage-ai/mage-ai/commit/f63cd00f6a3be372397d37a4c9a49bfaf50d7650
- https://github.com/mage-ai/mage-ai/security/advisories/GHSA-c6mm-2g84-v4m7
Get alerted when CVE-2023-31143 or the next vulnerability affects your stack