What’s Vulnerable › Vulnerabilities
CVE-2023-31146: Vyper vulnerable to OOB DynArray access when array is on both LHS and RHS of an assignment
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-11 · updated 2026-06-17
- Weakness: CWE-787
Description
Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, during codegen, the length word of a dynarray is written before the data, which can result in out-of-bounds array access in the case where the dynarray is on both the lhs and rhs of an assignment. The issue can cause data corruption across call frames. The expected behavior is to revert due to out-of-bounds array access. Version 0.3.8 contains a patch for this issue.
Affected products
- vyperlang vyper: before 0.3.8 — fixed in 0.3.8
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/commit/4f8289a81206f767df1900ac48f485d90fc87edb
- https://github.com/vyperlang/vyper/security/advisories/GHSA-3p37-3636-q8wv
- https://github.com/vyperlang/vyper/commit/4f8289a81206f767df1900ac48f485d90fc87edb
- https://github.com/vyperlang/vyper/security/advisories/GHSA-3p37-3636-q8wv
Get alerted when CVE-2023-31146 or the next vulnerability affects your stack