What’s Vulnerable › Vulnerabilities
CVE-2023-3115: Incorrect User Management in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-29 · updated 2026-06-17
- Weakness: CWE-286
Description
An issue has been discovered in GitLab EE affecting all versions affecting all versions from 11.11 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1. Single Sign On restrictions were not correctly enforced for indirect project members accessing public members-only project repositories.
Affected products
- GitLab: from 11.11 before 16.2.8; from 16.3.0 before 16.3.5; 16.4.0 — fixed in 16.2.8, 16.3.5
How to fix
Upgrade to a fixed version: GitLab 16.2.8, 16.3.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/414367
- https://hackerone.com/reports/2004158
- https://gitlab.com/gitlab-org/gitlab/-/issues/414367
- https://hackerone.com/reports/2004158
Get alerted when CVE-2023-3115 or the next vulnerability affects your stack