What’s Vulnerable › Vulnerabilities
CVE-2023-31209: Command injection via active checks and REST API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-10 · updated 2026-10-24
- Weakness: CWE-78
Description
Improper neutralization of active check command arguments in Checkmk < 2.1.0p32, < 2.0.0p38, < 2.2.0p4 leads to arbitrary command execution for authenticated users.
Affected products
- Checkmk GmbH Checkmk: 2.0.0, 2.0.0-b1, 2.0.0-b2, 2.0.0-b3, 2.0.0-b4, 2.0.0-b5 (+95)
- Tribe29 Checkmk: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Tribe29 Checkmk 2.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-31209 or the next vulnerability affects your stack