What’s Vulnerable › Vulnerabilities
CVE-2023-3142: Cross-site Scripting (XSS) - Stored in microweber/microweber
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 2.0.
Affected products
- microweber/microweber: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: microweber/microweber 2.0. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/42efa981a2239d042d910069952d6276497bdcf1
- https://huntr.dev/bounties/d00686b0-f89a-4e14-98d7-b8dd3f92a6e5
- https://github.com/microweber/microweber/commit/42efa981a2239d042d910069952d6276497bdcf1
- https://huntr.dev/bounties/d00686b0-f89a-4e14-98d7-b8dd3f92a6e5
Get alerted when CVE-2023-3142 or the next vulnerability affects your stack