What’s Vulnerable › Vulnerabilities
CVE-2023-31432: Privilege issues in multiple commands
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-02 · updated 2026-06-17
- Weakness: CWE-269
Description
Through manipulation of passwords or other variables, using commands such as portcfgupload, configupload, license, myid, a non-privileged user could obtain root privileges in Brocade Fabric OS versions before Brocade Fabric OS v9.1.1c and v9.2.0.
Affected products
- Broadcom Brocade Fabric Operating System: before 9.1.1c — fixed in 9.1.1c
How to fix
Upgrade to a fixed version: Broadcom Brocade Fabric Operating System 9.1.1c. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20230908-0007/
- https://support.broadcom.com/external/content/SecurityAdvisories/0/22385
- https://security.netapp.com/advisory/ntap-20230908-0007/
- https://support.broadcom.com/external/content/SecurityAdvisories/0/22385
Get alerted when CVE-2023-31432 or the next vulnerability affects your stack