What’s Vulnerable › Vulnerabilities

CVE-2023-31436

Description

qfq_change_class in net/sched/sch_qfq.c in the Linux kernel before 6.2.13 allows an out-of-bounds write because lmax can exceed QFQ_MIN_LMAX.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.314, 4.19.282, 5.10.179, 5.15.109. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-31436 or the next vulnerability affects your stack