What’s Vulnerable › Vulnerabilities

CVE-2023-31486

Description

HTTP::Tiny before 0.083, a Perl core module since 5.13.9 and available standalone on CPAN, has an insecure default TLS configuration where users must opt in to verify certificates.

Affected products

How to fix

Upgrade to a fixed version: Http::Tiny Project Http::Tiny 0.083; perl 5.38.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-31486 or the next vulnerability affects your stack