What’s Vulnerable › Vulnerabilities
CVE-2023-31582
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-331
Description
jose4j before v0.9.3 allows attackers to set a low iteration count of 1000 or less.
Affected products
- Jose4J Project Jose4J: before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: Jose4J Project Jose4J 0.9.3. Check the vendor advisory for mitigations.
References
- https://bitbucket.org/b_c/jose4j/issues/203/insecure-support-of-setting-pbe-less-then
- https://github.com/KANIXB/JWTIssues/blob/main/jose4j%20issue.md
- https://bitbucket.org/b_c/jose4j/issues/203/insecure-support-of-setting-pbe-less-then
- https://github.com/KANIXB/JWTIssues/blob/main/jose4j%20issue.md
Get alerted when CVE-2023-31582 or the next vulnerability affects your stack