What’s Vulnerable › Vulnerabilities
CVE-2023-31664
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do of WSO2 API Manager before 4.2.0 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the tenantDomain parameter.
Affected products
- WSO2 API Manager: before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: WSO2 API Manager 4.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/adilkhan7/CVE-2023-31664
- https://github.com/wso2/api-manager/issues?q=is%3Aissue+is%3Aclosed+label%3AComponent%2FAPIM+closed%3A2022-04-05..2023-03-11
- https://github.com/wso2/product-apim/releases/tag/v4.2.0
- https://github.com/adilkhan7/CVE-2023-31664
- https://github.com/wso2/api-manager/issues?q=is%3Aissue+is%3Aclosed+label%3AComponent%2FAPIM+closed%3A2022-04-05..2023-03-11
- https://github.com/wso2/product-apim/releases/tag/v4.2.0
Get alerted when CVE-2023-31664 or the next vulnerability affects your stack