What’s Vulnerable › Vulnerabilities
CVE-2023-31671
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-14 · updated 2026-06-17
- Weakness: CWE-89
Description
PrestaShop postfinance <= 17.1.13 is vulnerable to SQL Injection via PostfinanceValidationModuleFrontController::postProcess().
Affected products
- Webbax Postfinance: before 17.1.14 — fixed in 17.1.14
How to fix
Upgrade to a fixed version: Webbax Postfinance 17.1.14. Check the vendor advisory for mitigations.
References
- https://friends-of-presta.github.io/security-advisories/modules/2023/06/13/postfinance.html
- https://shop.webbax.ch/modules-de-paiement/123-module-postfinance.html
- https://friends-of-presta.github.io/security-advisories/modules/2023/06/13/postfinance.html
- https://shop.webbax.ch/modules-de-paiement/123-module-postfinance.html
Get alerted when CVE-2023-31671 or the next vulnerability affects your stack