What’s Vulnerable › Vulnerabilities
CVE-2023-3170: tagDiv Composer < 4.2 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The tagDiv Composer WordPress plugin before 4.2, used as a companion by the Newspaper and Newsmag themes from tagDiv, does not validate and escape some settings, which could allow users with Admin privileges to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- tagDiv Composer: before 4.2 — fixed in 4.2
How to fix
Upgrade to a fixed version: tagDiv Composer 4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e95ff3c6-283b-4e5e-bea0-1f1375da08da
- https://wpscan.com/vulnerability/e95ff3c6-283b-4e5e-bea0-1f1375da08da
Get alerted when CVE-2023-3170 or the next vulnerability affects your stack