What’s Vulnerable › Vulnerabilities
CVE-2023-3182: Membership Plugin - Restrict Content < 3.2.3 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-17 · updated 2026-06-17
Description
The Membership WordPress plugin before 3.2.3 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- stellarwp Membership Plugin – Restrict Content: before 3.2.3 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: stellarwp Membership Plugin – Restrict Content 3.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/655a68ee-9447-41ca-899e-986a419fb7ed
- https://wpscan.com/vulnerability/655a68ee-9447-41ca-899e-986a419fb7ed
Get alerted when CVE-2023-3182 or the next vulnerability affects your stack