What’s Vulnerable › Vulnerabilities
CVE-2023-31871
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-18 · updated 2026-06-17
- Weakness: CWE-732
Description
OpenText Documentum Content Server before 23.2 has a flaw that allows for privilege escalation from a non-privileged Documentum user to root. The software comes prepackaged with a root owned SUID binary dm_secure_writer. The binary has security controls in place preventing creation of a file in a non-owned directory, or as the root user. However, these controls can be carefully bypassed to allow for an arbitrary file write as root.
Affected products
- OpenText Documentum Content Server: before 23.2 — fixed in 23.2
How to fix
Upgrade to a fixed version: OpenText Documentum Content Server 23.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/picar0jsu/a8e623639da34f36202ce5e436668de7
- https://gist.github.com/picar0jsu/a8e623639da34f36202ce5e436668de7
Get alerted when CVE-2023-31871 or the next vulnerability affects your stack