What’s Vulnerable › Vulnerabilities
CVE-2023-31928: XSS vulnerability in Brocade Webtools
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability exists in Brocade Webtools PortSetting.html of Brocade Fabric OS version before Brocade Fabric OS v9.2.0 that could allow a remote unauthenticated attacker to execute arbitrary JavaScript code in a target user’s session with the Brocade Webtools application.
Affected products
- Broadcom Brocade Fabric Operating System: before 9.2.0 — fixed in 9.2.0
How to fix
Upgrade to a fixed version: Broadcom Brocade Fabric Operating System 9.2.0. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20230908-0007/
- https://support.broadcom.com/external/content/SecurityAdvisories/0/22390
- https://security.netapp.com/advisory/ntap-20230908-0007/
- https://support.broadcom.com/external/content/SecurityAdvisories/0/22390
Get alerted when CVE-2023-31928 or the next vulnerability affects your stack