What’s Vulnerable › Vulnerabilities
CVE-2023-31998
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-18 · updated 2026-06-17
- Weakness: CWE-787
Description
A heap overflow vulnerability found in EdgeRouters and Aircubes allows a malicious actor to interrupt UPnP service to said devices.
Affected products
- Ui Aircube Firmware: before 2.8.9 — fixed in 2.8.9
- EdgeMAX EdgeRouter: 2.0.9
How to fix
Upgrade to a fixed version: Ui Aircube Firmware 2.8.9. Check the vendor advisory for mitigations.
References
- https://community.ui.com/releases/Security-Advisory-Bulletin-033-033/17f7c7c0-830b-4625-a2ee-e90e514e7b0f
- https://community.ui.com/releases/Security-Advisory-Bulletin-033-033/17f7c7c0-830b-4625-a2ee-e90e514e7b0f
Get alerted when CVE-2023-31998 or the next vulnerability affects your stack