What’s Vulnerable › Vulnerabilities
CVE-2023-3204: Materialis <= 1.1.24 - Missing Authorization to Limited Arbitrary Options Update
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-20 · updated 2026-06-17
- Weakness: CWE-862
Description
The Materialis theme for WordPress is vulnerable to limited arbitrary options updates in versions up to, and including, 1.1.24. This is due to missing authorization checks on the companion_disable_popup() function called via an AJAX action. This makes it possible for authenticated attackers, with minimal permissions such as subscribers, to modify any option on the site to a numerical value.
Affected products
- extendthemes Materialis: before 1.1.30 — fixed in 1.1.30
How to fix
Upgrade to a fixed version: extendthemes Materialis 1.1.30. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/browser/materialis/1.1.20/inc/companion.php#L45
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=231816%40materialis&new=231816%40materialis&sfp_email=&sfph_mail=#file6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a2e05094-8344-4388-a703-518daf3d2948?source=cve
- https://themes.trac.wordpress.org/browser/materialis/1.1.20/inc/companion.php#L45
- https://themes.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=231816%40materialis&new=231816%40materialis&sfp_email=&sfph_mail=#file6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a2e05094-8344-4388-a703-518daf3d2948?source=cve
Get alerted when CVE-2023-3204 or the next vulnerability affects your stack