What’s Vulnerable › Vulnerabilities

CVE-2023-3205: Inefficient Regular Expression Complexity in GitLab

Description

An issue has been discovered in GitLab affecting all versions starting from 15.11 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. An authenticated user could trigger a denial of service when importing or cloning malicious content.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.1.5, 16.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3205 or the next vulnerability affects your stack