What’s Vulnerable › Vulnerabilities
CVE-2023-32058: Vyper vulnerable to integer overflow in loop
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-11 · updated 2026-06-17
- Weakness: CWE-190
Description
Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, due to missing overflow check for loop variables, by assigning the iterator of a loop to a variable, it is possible to overflow the type of the latter. The issue seems to happen only in loops of type `for i in range(a, a + N)` as in loops of type `for i in range(start, stop)` and `for i in range(stop)`, the compiler is able to raise a `TypeMismatch` when trying to overflow the variable. The problem has been patched in version 0.3.8.
Affected products
- vyperlang vyper: before 0.3.8 — fixed in 0.3.8
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/commit/3de1415ee77a9244eb04bdb695e249d3ec9ed868
- https://github.com/vyperlang/vyper/security/advisories/GHSA-6r8q-pfpv-7cgj
- https://github.com/vyperlang/vyper/commit/3de1415ee77a9244eb04bdb695e249d3ec9ed868
- https://github.com/vyperlang/vyper/security/advisories/GHSA-6r8q-pfpv-7cgj
Get alerted when CVE-2023-32058 or the next vulnerability affects your stack