What’s Vulnerable › Vulnerabilities
CVE-2023-32059: Vyper vulnerable to incorrect ordering of arguments for kwargs passed to internal calls
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-11 · updated 2026-06-17
- Weakness: CWE-683
Description
Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, internal calls with default arguments are compiled incorrectly. Depending on the number of arguments provided in the call, the defaults are added not right-to-left, but left-to-right. If the types are incompatible, typechecking is bypassed. The ability to pass kwargs to internal functions is an undocumented feature that is not well known about. The issue is patched in version 0.3.8.
Affected products
- vyperlang vyper: before 0.3.8 — fixed in 0.3.8
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/commit/c3e68c302aa6e1429946473769dd1232145822ac
- https://github.com/vyperlang/vyper/security/advisories/GHSA-ph9x-4vc9-m39g
- https://github.com/vyperlang/vyper/commit/c3e68c302aa6e1429946473769dd1232145822ac
- https://github.com/vyperlang/vyper/security/advisories/GHSA-ph9x-4vc9-m39g
Get alerted when CVE-2023-32059 or the next vulnerability affects your stack