What’s Vulnerable › Vulnerabilities
CVE-2023-32079: Netmaker Privilige Escalation Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-24 · updated 2026-06-17
- Weakness: CWE-915
Description
Netmaker makes networks with WireGuard. A Mass assignment vulnerability was found in versions prior to 0.17.1 and 0.18.6 that allows a non-admin user to escalate privileges to those of an admin user. The issue is patched in 0.17.1 and fixed in 0.18.6. If Users are using 0.17.1, they should run `docker pull gravitl/netmaker:v0.17.1` and `docker-compose up -d`. This will switch them to the patched users If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later. As a workaround, someone using version 0.17.1 can pull the latest docker image of the backend and restart the server.
Affected products
- gravitl netmaker: before 0.17.1; from 0.18.0 through 0.18.5 — fixed in 0.17.1
How to fix
Upgrade to a fixed version: gravitl netmaker 0.17.1. Check the vendor advisory for mitigations.
References
- https://github.com/gravitl/netmaker/security/advisories/GHSA-826j-8wp2-4x6q
- https://github.com/gravitl/netmaker/security/advisories/GHSA-826j-8wp2-4x6q
Get alerted when CVE-2023-32079 or the next vulnerability affects your stack