What’s Vulnerable › Vulnerabilities
CVE-2023-32142: D-Link DAP-1360 webproc var:page Stack-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-121
Description
D-Link DAP-1360 webproc var:page Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of D-Link DAP-1360 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of requests to the /cgi-bin/webproc endpoint. When parsing the var:page parameter, the process does not properly validate the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of root. . Was ZDI-CAN-18422.
Affected products
- Dlink Dap-1360 Firmware: before 6.15eub01 — fixed in 6.15eub01
- D-Link DAP-2020: before 1.03rc004 — fixed in 1.03rc004
How to fix
Upgrade to a fixed version: Dlink Dap-1360 Firmware 6.15eub01; D-Link DAP-2020 1.03rc004. Check the vendor advisory for mitigations.
References
- https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10324
- https://www.zerodayinitiative.com/advisories/ZDI-23-534/
- https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10324
- https://www.zerodayinitiative.com/advisories/ZDI-23-534/
Get alerted when CVE-2023-32142 or the next vulnerability affects your stack