What’s Vulnerable › Vulnerabilities
CVE-2023-32170: Unified Automation UaGateway OPC UA Server Improper Input Validation Denial-of-Service Vulnerability
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-20
Description
Unified Automation UaGateway OPC UA Server Improper Input Validation Denial-of-Service Vulnerability. This vulnerability allows remote attackers to create a denial-of-service condition on affected installations of Unified Automation UaGateway. User interaction is required to exploit this vulnerability in that the target must choose to accept a client certificate. The specific flaw exists within the processing of client certificates. The issue results from the lack of proper validation of certificate data. An attacker can leverage this vulnerability to create a denial-of-service condition on the system. Was ZDI-CAN-20494.
Affected products
- Unified Automation UaGateway: before 1.5.13.487 — fixed in 1.5.13.487
How to fix
Upgrade to a fixed version: Unified Automation UaGateway 1.5.13.487. Check the vendor advisory for mitigations.
References
- https://documentation.unified-automation.com/uagateway/1.5.14/CHANGELOG.txt
- https://www.zerodayinitiative.com/advisories/ZDI-23-775/
- https://documentation.unified-automation.com/uagateway/1.5.14/CHANGELOG.txt
- https://www.zerodayinitiative.com/advisories/ZDI-23-775/
Get alerted when CVE-2023-32170 or the next vulnerability affects your stack