What’s Vulnerable › Vulnerabilities
CVE-2023-32174: Unified Automation UaGateway NodeManagerOpcUa Use-After-Free Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-416
Description
Unified Automation UaGateway NodeManagerOpcUa Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Unified Automation UaGateway. Authentication is required to exploit this vulnerability when the product is in its default configuration. The specific flaw exists within the handling of NodeManagerOpcUa objects. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. . Was ZDI-CAN-20577.
Affected products
- Unified Automation UaGateway: before 1.5.14.495 — fixed in 1.5.14.495
How to fix
Upgrade to a fixed version: Unified Automation UaGateway 1.5.14.495. Check the vendor advisory for mitigations.
References
- https://documentation.unified-automation.com/uagateway/1.5.14/CHANGELOG.txt
- https://www.zerodayinitiative.com/advisories/ZDI-23-780/
- https://documentation.unified-automation.com/uagateway/1.5.14/CHANGELOG.txt
- https://www.zerodayinitiative.com/advisories/ZDI-23-780/
Get alerted when CVE-2023-32174 or the next vulnerability affects your stack