What’s Vulnerable › Vulnerabilities
CVE-2023-32190: mlocate's %post script allows RUN_UPDATEDB_AS user to make arbitrary files world readable
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-125
Description
mlocate's %post script allows RUN_UPDATEDB_AS user to make arbitrary files world readable by abusing insecure file operations that run with root privileges.
Affected products
- SUSE openSUSE Tumbleweed: before 0.26-37.1 — fixed in 0.26-37.1
How to fix
Upgrade to a fixed version: SUSE openSUSE Tumbleweed 0.26-37.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-32190 or the next vulnerability affects your stack