What’s Vulnerable › Vulnerabilities
CVE-2023-32192: Rancher API Server Cross-site Scripting Vulnerability
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-80
Description
A vulnerability has been identified in which unauthenticated cross-site scripting (XSS) in the API Server's public API endpoint can be exploited, allowing an attacker to execute arbitrary JavaScript code in the victim browser
Affected products
- Kubernetes kube-apiserver: before 0.0.0-20240207153957-4fd7d821d952 — fixed in 0.0.0-20240207153957-4fd7d821d952
How to fix
Upgrade to a fixed version: Kubernetes kube-apiserver 0.0.0-20240207153957-4fd7d821d952. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2023-32192
- https://github.com/rancher/apiserver/security/advisories/GHSA-833m-37f7-jq55
Get alerted when CVE-2023-32192 or the next vulnerability affects your stack