What’s Vulnerable › Vulnerabilities
CVE-2023-32193: Norman API Cross-site Scripting Vulnerability
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-80
Description
A vulnerability has been identified in which unauthenticated cross-site scripting (XSS) in Norman's public API endpoint can be exploited. This can lead to an attacker exploiting the vulnerability to trigger JavaScript code and execute commands remotely.
Affected products
- Rancher Norman: before 0.0.0-20240207153100-3bb70b772b52 — fixed in 0.0.0-20240207153100-3bb70b772b52
How to fix
Upgrade to a fixed version: Rancher Norman 0.0.0-20240207153100-3bb70b772b52. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2023-32193
- https://github.com/rancher/norman/security/advisories/GHSA-r8f4-hv23-6qp6
Get alerted when CVE-2023-32193 or the next vulnerability affects your stack