What’s Vulnerable › Vulnerabilities
CVE-2023-32198: Steve doesn’t verify a server’s certificate and is susceptible to man-in-the-middle (MitM) attacks
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-16
- Weakness: CWE-295
Description
A vulnerability has been identified in Steve where by default it was using an insecure option that did not validate the certificate presented by the remote server while performing a TLS connection. This could allow the execution of a man-in-the-middle (MitM) attack against services using Steve.
Affected products
- SUSE steve: from 0.2.0 before 0.2.1; from 0.3.0 before 0.3.3; from 0.4.0 before 0.4.4; from 0.5.0 before 0.5.13 — fixed in 0.2.1, 0.3.3, 0.4.4, 0.5.13
How to fix
Upgrade to a fixed version: SUSE steve 0.2.1, 0.3.3, 0.4.4, 0.5.13. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2023-32198
- https://github.com/rancher/steve/security/advisories/GHSA-95fc-g4gj-mqmx
Get alerted when CVE-2023-32198 or the next vulnerability affects your stack