What’s Vulnerable › Vulnerabilities
CVE-2023-32249: ksmbd: not allow guest user on multichannel
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-16 · updated 2026-08-15
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: not allow guest user on multichannel This patch return STATUS_NOT_SUPPORTED if binding session is guest.
Affected products
- Linux kernel: from 5.15 before 5.15.112; from 5.16 before 6.1.28; from 6.2 before 6.2.15; from 6.3 before 6.3.2 — fixed in 5.15.112, 6.1.28, 6.2.15, 6.3.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.112, 6.1.28, 6.2.15, 6.3.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/088131b7b01099720a528a72005ff17868705d40
- https://git.kernel.org/stable/c/1f0490586544455e5be698be2e6c30077b4ec461
- https://git.kernel.org/stable/c/3353ab2df5f68dab7da8d5ebb427a2d265a1f2b2
- https://git.kernel.org/stable/c/4a98e859c4673013385a54084e0cd865695ca072
- https://git.kernel.org/stable/c/ed76d3a8910be06cd4e4ba63bf6075bf903945a1
Get alerted when CVE-2023-32249 or the next vulnerability affects your stack