What’s Vulnerable › Vulnerabilities
CVE-2023-32301: Discourse's canonical url not being used for topic embeddings
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-13 · updated 2026-06-17
- Weakness: CWE-116
Description
Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, multiple duplicate topics could be created if topic embedding is enabled. This issue is patched in version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches. As a workaround, disable topic embedding if it has been enabled.
Affected products
- discourse: before 3.0.4; 3.1.0-beta1, 3.1.0-beta2, 3.1.0-beta3, 3.1.0-beta4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: discourse 3.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-p2jx-m2j5-hqh4
- https://github.com/discourse/discourse/security/advisories/GHSA-p2jx-m2j5-hqh4
Get alerted when CVE-2023-32301 or the next vulnerability affects your stack