What’s Vulnerable › Vulnerabilities
CVE-2023-32305: aiven-extras PostgreSQL Privilege Escalation Through Overloaded Search Path
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-12 · updated 2026-06-17
- Weakness: CWE-20
Description
aiven-extras is a PostgreSQL extension. Versions prior to 1.1.9 contain a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages missing schema qualifiers on privileged functions called by the aiven-extras extension. A low privileged user can create objects that collide with existing function names, which will then be executed instead. Exploiting this vulnerability could allow a low privileged user to acquire `superuser` privileges, which would allow full, unrestricted access to all data and database functions. And could lead to arbitrary code execution or data access on the underlying host as the `postgres` user. The issue has been patched as of version 1.1.9.
Affected products
- aiven-extras: before 1.1.9 — fixed in 1.1.9
How to fix
Upgrade to a fixed version: aiven-extras 1.1.9. Check the vendor advisory for mitigations.
References
- https://github.com/aiven/aiven-extras/commit/8682ae01bec0791708bf25791786d776e2fb0250
- https://github.com/aiven/aiven-extras/security/advisories/GHSA-7r4w-fw4h-67gp
- https://security.netapp.com/advisory/ntap-20230616-0006/
- https://github.com/aiven/aiven-extras/commit/8682ae01bec0791708bf25791786d776e2fb0250
- https://github.com/aiven/aiven-extras/security/advisories/GHSA-7r4w-fw4h-67gp
- https://security.netapp.com/advisory/ntap-20230616-0006/
Get alerted when CVE-2023-32305 or the next vulnerability affects your stack