What’s Vulnerable › Vulnerabilities
CVE-2023-32310: DataEase API interface has IDOR vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-01 · updated 2026-06-17
- Weakness: CWE-639
Description
DataEase is an open source data visualization and analysis tool. The API interface for DataEase delete dashboard and delete system messages is vulnerable to insecure direct object references (IDOR). This could result in a user deleting another user's dashboard or messages or interfering with the interface for marking messages read. The vulnerability has been fixed in v1.18.7. There are no known workarounds aside from upgrading.
Affected products
- dataease: before 1.18.7 — fixed in 1.18.7
How to fix
Upgrade to a fixed version: dataease 1.18.7. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/72f428e87b5395c03d2f94ef6185fc247ddbc8dc
- https://github.com/dataease/dataease/pull/5342
- https://github.com/dataease/dataease/releases/tag/v1.18.7
- https://github.com/dataease/dataease/security/advisories/GHSA-7hv6-gv38-78wj
- https://github.com/dataease/dataease/commit/72f428e87b5395c03d2f94ef6185fc247ddbc8dc
- https://github.com/dataease/dataease/pull/5342
- https://github.com/dataease/dataease/releases/tag/v1.18.7
- https://github.com/dataease/dataease/security/advisories/GHSA-7hv6-gv38-78wj
Get alerted when CVE-2023-32310 or the next vulnerability affects your stack