What’s Vulnerable › Vulnerabilities
CVE-2023-32311: The CloudExplorer Lite missing permissions check
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-26 · updated 2026-06-17
- Weakness: CWE-862
Description
CloudExplorer Lite is an open source cloud management platform. In CloudExplorer Lite prior to version 1.1.0 users organization/workspace permissions are not properly checked. This allows users to add themselves to any organization. This vulnerability has been fixed in v1.1.0. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- fit2cloud Cloudexplorer: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: fit2cloud Cloudexplorer 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-hxjq-g9qv-pwq5
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-hxjq-g9qv-pwq5
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-hxjq-g9qv-pwq5
Get alerted when CVE-2023-32311 or the next vulnerability affects your stack