What’s Vulnerable › Vulnerabilities
CVE-2023-32314: Sandbox Escape
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-15 · updated 2026-06-17
- Weakness: CWE-74
Description
vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- patriksimek vm2: before 3.9.18 — fixed in 3.9.18
How to fix
Upgrade to a fixed version: patriksimek vm2 3.9.18. Check the vendor advisory for mitigations.
References
- https://gist.github.com/arkark/e9f5cf5782dec8321095be3e52acf5ac
- https://github.com/patriksimek/vm2/commit/d88105f99752305c5b8a77b63ddee3ec86912daf
- https://github.com/patriksimek/vm2/releases/tag/3.9.18
- https://github.com/patriksimek/vm2/security/advisories/GHSA-whpj-8f3w-67p5
- https://gist.github.com/arkark/e9f5cf5782dec8321095be3e52acf5ac
- https://github.com/patriksimek/vm2/commit/d88105f99752305c5b8a77b63ddee3ec86912daf
- https://github.com/patriksimek/vm2/releases/tag/3.9.18
- https://github.com/patriksimek/vm2/security/advisories/GHSA-whpj-8f3w-67p5
Get alerted when CVE-2023-32314 or the next vulnerability affects your stack