What’s Vulnerable › Vulnerabilities
CVE-2023-32325: Cross-site scripting in PostHog-js
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-27 · updated 2026-06-17
- Weakness: CWE-79
Description
PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.
Affected products
- posthog-js: before 1.57.2 — fixed in 1.57.2
How to fix
Upgrade to a fixed version: posthog-js 1.57.2. Check the vendor advisory for mitigations.
References
- https://github.com/PostHog/posthog-js/commit/67e07eb8bb271a3a6f4aa251382e4d25abb385a0
- https://github.com/PostHog/posthog-js/security/advisories/GHSA-8775-5hwv-wr6v
- https://github.com/PostHog/posthog-js/commit/67e07eb8bb271a3a6f4aa251382e4d25abb385a0
- https://github.com/PostHog/posthog-js/security/advisories/GHSA-8775-5hwv-wr6v
Get alerted when CVE-2023-32325 or the next vulnerability affects your stack