What’s Vulnerable › Vulnerabilities
CVE-2023-32460
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-08 · updated 2026-06-17
- Weakness: CWE-306
Description
Dell PowerEdge BIOS contains an improper privilege management security vulnerability. An unauthenticated local attacker could potentially exploit this vulnerability, leading to privilege escalation.
Affected products
- Dell Dss 8440 Firmware: before 2.20.0 — fixed in 2.20.0
- Dell Emc Nx440 Firmware: before 2.15.1 — fixed in 2.15.1
- Dell Emc Storage Nx3240 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Emc Storage Nx3340 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Emc Xc Core 6420 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Emc Xc Core Xc450 Firmware: before 1.12.1 — fixed in 1.12.1
- Dell Emc Xc Core Xc640 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Emc Xc Core Xc650 Firmware: before 1.12.1 — fixed in 1.12.1
- Dell Emc Xc Core Xc6520 Firmware: before 1.12.1 — fixed in 1.12.1
- Dell Emc Xc Core Xc740Xd2 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Emc Xc Core Xc740Xd Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Emc Xc Core Xc750 Firmware: before 1.12.1 — fixed in 1.12.1
- Dell Emc Xc Core Xc750Xa Firmware: before 1.12.1 — fixed in 1.12.1
- Dell Emc Xc Core Xc7525 Firmware: before 2.13.3 — fixed in 2.13.3
- Dell Emc Xc Core Xc940 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Emc Xc Core Xcxr2 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Nx3230 Firmware: before 2.18.1 — fixed in 2.18.1
- Dell Nx3330 Firmware: before 2.18.1 — fixed in 2.18.1
- Dell Nx430 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Poweredge C4130 Firmware: before 2.18.1 — fixed in 2.18.1
- Dell Poweredge C4140 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Poweredge C6320 Firmware: before 2.18.2 — fixed in 2.18.2
- Dell Poweredge C6420 Firmware: before 2.20.1 — fixed in 2.20.1
- Dell Poweredge C6520 Firmware: before 1.12.1 — fixed in 1.12.1
- Dell Poweredge C6525 Firmware: before 2.13.3 — fixed in 2.13.3
- Dell Poweredge C6615 Firmware: before 1.1.2 — fixed in 1.1.2
- Dell Poweredge C6620 Firmware: before 1.6.6 — fixed in 1.6.6
- Dell Poweredge Fc430 Firmware: before 2.18.1 — fixed in 2.18.1
- Dell Poweredge Fc630 Firmware: before 2.18.1 — fixed in 2.18.1
- Dell Poweredge Fc640 Firmware: before 2.20.1 — fixed in 2.20.1
How to fix
Upgrade to a fixed version: Dell Dss 8440 Firmware 2.20.0; Dell Emc Nx440 Firmware 2.15.1; Dell Emc Storage Nx3240 Firmware 2.20.1; Dell Emc Storage Nx3340 Firmware 2.20.1; Dell Emc Xc Core 6420 Firmware 2.20.1; Dell Emc Xc Core Xc450 Firmware 1.12.1; Dell Emc Xc Core Xc640 Firmware 2.20.1; Dell Emc Xc Core Xc650 Firmware 1.12.1; Dell Emc Xc Core Xc6520 Firmware 1.12.1; Dell Emc Xc Core Xc740Xd2 Firmware 2.20.1; Dell Emc Xc Core Xc740Xd Firmware 2.20.1; Dell Emc Xc Core Xc750 Firmware 1.12.1. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000219550/dsa-2023-361-security-update-for-dell-poweredge-server-bios-for-an-improper-privilege-management-security-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000219550/dsa-2023-361-security-update-for-dell-poweredge-server-bios-for-an-improper-privilege-management-security-vulnerability
Get alerted when CVE-2023-32460 or the next vulnerability affects your stack