What’s Vulnerable › Vulnerabilities
CVE-2023-32480
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-20
Description
Dell BIOS contains an Improper Input Validation vulnerability. An unauthenticated physical attacker may potentially exploit this vulnerability to perform arbitrary code execution.
Affected products
- Dell Alienware M15 R7 Firmware: before 1.17.0 — fixed in 1.17.0
- Dell G15 5510 Firmware: before 1.19.0 — fixed in 1.19.0
- Dell G15 5520 Firmware: before 1.17.0 — fixed in 1.17.0
- Dell Inspiron 14 5410 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Inspiron 14 5418 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Inspiron 15 5510 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Inspiron 15 5518 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Inspiron 16 7620 2-In-1 Firmware: before 1.12.1 — fixed in 1.12.1
- Dell Inspiron 3520 Firmware: before 1.15.0 — fixed in 1.15.0
- Dell Inspiron 5410 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Inspiron 5420 Firmware: before 1.14.1 — fixed in 1.14.1
- Dell Inspiron 5620 Firmware: before 1.14.1 — fixed in 1.14.1
- Dell Inspiron 7420 Firmware: before 1.12.1 — fixed in 1.12.1
- Dell Inspiron 7510 Firmware: before 1.16.1 — fixed in 1.16.1
- Dell Inspiron 7610 Firmware: before 1.16.1 — fixed in 1.16.1
- Dell Latitude 3320 Firmware: before 1.22.2 — fixed in 1.22.2
- Dell Latitude 3420 Firmware: before 1.29.0 — fixed in 1.29.0
- Dell Latitude 3430 Firmware: before 1.10.1 — fixed in 1.10.1
- Dell Latitude 3520 Firmware: before 1.29.0 — fixed in 1.29.0
- Dell Latitude 3530 Firmware: before 1.10.1 — fixed in 1.10.1
- Dell Precision 5760 Firmware: before 1.20.1 — fixed in 1.20.1
- Dell Precision 5770 Firmware: before 1.17.1 — fixed in 1.17.1
- Dell Vostro 3420 Firmware: before 1.15.0 — fixed in 1.15.0
- Dell Vostro 3520 Firmware: before 1.15.0 — fixed in 1.15.0
- Dell Vostro 5410 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Vostro 5510 Firmware: before 2.19.1 — fixed in 2.19.1
- Dell Vostro 5620 Firmware: before 1.14.1 — fixed in 1.14.1
- Dell Vostro 7510 Firmware: before 1.16.1 — fixed in 1.16.1
- Dell Xps 13 9315 2-In-1 Firmware: before 1.8.1 — fixed in 1.8.1
- Dell Xps 17 9710 Firmware: before 1.20.1 — fixed in 1.20.1
How to fix
Upgrade to a fixed version: Dell Alienware M15 R7 Firmware 1.17.0; Dell G15 5510 Firmware 1.19.0; Dell G15 5520 Firmware 1.17.0; Dell Inspiron 14 5410 Firmware 2.19.1; Dell Inspiron 14 5418 Firmware 2.19.1; Dell Inspiron 15 5510 Firmware 2.19.1; Dell Inspiron 15 5518 Firmware 2.19.1; Dell Inspiron 16 7620 2-In-1 Firmware 1.12.1; Dell Inspiron 3520 Firmware 1.15.0; Dell Inspiron 5410 Firmware 2.19.1; Dell Inspiron 5420 Firmware 1.14.1; Dell Inspiron 5620 Firmware 1.14.1. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000214779/dsa-2023-175-dell-client-bios-security-update-for-an-improper-input-validation-vulnerability
- https://www.dell.com/support/kbdoc/en-us/000214779/dsa-2023-175-dell-client-bios-security-update-for-an-improper-input-validation-vulnerability
Get alerted when CVE-2023-32480 or the next vulnerability affects your stack