What’s Vulnerable › Vulnerabilities
CVE-2023-32484
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-15 · updated 2026-06-17
- Weakness: CWE-20
Description
Dell Networking Switches running Enterprise SONiC versions 4.1.0, 4.0.5, 3.5.4 and below contains an improper input validation vulnerability. A remote unauthenticated malicious user may exploit this vulnerability and escalate privileges up to the highest administrative level. This is a Critical vulnerability affecting certain protocols, Dell recommends customers to upgrade at the earliest opportunity.
Affected products
- Dell Enterprise SONiC OS: from 3.5.0 before 3.5.5; from 4.0.0 before 4.0.6; 4.1.0 — fixed in 3.5.5, 4.0.6
How to fix
Upgrade to a fixed version: Dell Enterprise SONiC OS 3.5.5, 4.0.6. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000216586/dsa-2023-284-security-update-for-dell-emc-enterprise-sonic-os-command-injection-vulnerability-when-using-remote-user-authentication
- https://www.dell.com/support/kbdoc/en-us/000216586/dsa-2023-284-security-update-for-dell-emc-enterprise-sonic-os-command-injection-vulnerability-when-using-remote-user-authentication
Get alerted when CVE-2023-32484 or the next vulnerability affects your stack