What’s Vulnerable › Vulnerabilities
CVE-2023-3263
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-289
Description
The Dataprobe iBoot PDU running firmware version 1.43.03312023 or earlier is vulnerable to authentication bypass in the REST API due to the mishandling of special characters when parsing credentials.Successful exploitation allows the malicious agent to obtain a valid authorization token and read information relating to the state of the relays and power distribution.
Affected products
- Dataprobe Iboot-Pdu4-C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4A-C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4A-C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4A-N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4A-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4Sa-C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4Sa-C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4Sa-N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4Sa-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-2C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-2C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-2N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-2N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8Sa-2N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8Sa-C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8Sa-N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8Sa-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
How to fix
Upgrade to a fixed version: Dataprobe Iboot-Pdu4-C20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4-N20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4A-C10 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4A-C20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4A-N15 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4A-N20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4Sa-C10 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4Sa-C20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4Sa-N15 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4Sa-N20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu8A-2C10 Firmware 1.44.0804202; Dataprobe Iboot-Pdu8A-2C20 Firmware 1.44.0804202. Check the vendor advisory for mitigations.
References
- https://www.trellix.com/en-us/about/newsroom/stories/research/the-threat-lurking-in-data-centers.html
- https://www.trellix.com/en-us/about/newsroom/stories/research/the-threat-lurking-in-data-centers.html
Get alerted when CVE-2023-3263 or the next vulnerability affects your stack