What’s Vulnerable › Vulnerabilities
CVE-2023-32636
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-14 · updated 2026-10-15
- Weakness: CWE-400
Description
A flaw was found in glib, where the gvariant deserialization code is vulnerable to a denial of service introduced by additional input validation added to resolve CVE-2023-29499. The offset table validation may be very slow. This bug does not affect any released version of glib but does affect glib distributors who followed the guidance of glib developers to backport the initial fix for CVE-2023-29499.
Affected products
- GNOME GLib: before 2.74.4 — fixed in 2.74.4
How to fix
Upgrade to a fixed version: GNOME GLib 2.74.4. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/glib/-/issues/2841
- https://https://discourse.gnome.org/t/multiple-fixes-for-gvariant-normalisation-issues-in-glib/12835
- https://security.netapp.com/advisory/ntap-20231110-0002/
- https://gitlab.gnome.org/GNOME/glib/-/issues/2841
- https://https://discourse.gnome.org/t/multiple-fixes-for-gvariant-normalisation-issues-in-glib/12835
- https://security.netapp.com/advisory/ntap-20231110-0002/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2023-32636 or the next vulnerability affects your stack