What’s Vulnerable › Vulnerabilities
CVE-2023-3264
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-798
Description
The Dataprobe iBoot PDU running firmware version 1.43.03312023 or earlier uses hard-coded credentials for all interactions with the internal Postgres database. A malicious agent with the ability to execute operating system commands on the device can leverage this vulnerability to read, modify, or delete arbitrary database records.
Affected products
- CyberPower PowerPanel Enterprise: before 2.6.9 — fixed in 2.6.9
- Dataprobe Iboot-Pdu4-C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4A-C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4A-C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4A-N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4A-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4Sa-C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4Sa-C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4Sa-N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu4Sa-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-2C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-2C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-2N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-2N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-C20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8A-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8Sa-2N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8Sa-C10 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8Sa-N15 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
- Dataprobe Iboot-Pdu8Sa-N20 Firmware: before 1.44.0804202 — fixed in 1.44.0804202
How to fix
Upgrade to a fixed version: CyberPower PowerPanel Enterprise 2.6.9; Dataprobe Iboot-Pdu4-C20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4-N20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4A-C10 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4A-C20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4A-N15 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4A-N20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4Sa-C10 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4Sa-C20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4Sa-N15 Firmware 1.44.0804202; Dataprobe Iboot-Pdu4Sa-N20 Firmware 1.44.0804202; Dataprobe Iboot-Pdu8A-2C10 Firmware 1.44.0804202. Check the vendor advisory for mitigations.
References
- https://www.trellix.com/en-us/about/newsroom/stories/research/the-threat-lurking-in-data-centers.html
- https://www.trellix.com/en-us/about/newsroom/stories/research/the-threat-lurking-in-data-centers.html
Get alerted when CVE-2023-3264 or the next vulnerability affects your stack