What’s Vulnerable › Vulnerabilities
CVE-2023-32643
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-14 · updated 2026-10-15
- Weakness: CWE-122
Description
A flaw was found in GLib. The GVariant deserialization code is vulnerable to a heap buffer overflow introduced by the fix for CVE-2023-32665. This bug does not affect any released version of GLib, but does affect GLib distributors who followed the guidance of GLib developers to backport the initial fix for CVE-2023-32665.
Affected products
- GNOME GLib: before 2.75.1 — fixed in 2.75.1
How to fix
Upgrade to a fixed version: GNOME GLib 2.75.1. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/glib/-/issues/2840
- https://https://discourse.gnome.org/t/multiple-fixes-for-gvariant-normalisation-issues-in-glib/12835
- https://security.netapp.com/advisory/ntap-20240426-0005/
- https://gitlab.gnome.org/GNOME/glib/-/issues/2840
- https://https://discourse.gnome.org/t/multiple-fixes-for-gvariant-normalisation-issues-in-glib/12835
- https://security.netapp.com/advisory/ntap-20240426-0005/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2023-32643 or the next vulnerability affects your stack