What’s Vulnerable › Vulnerabilities
CVE-2023-32665: Gvariant deserialisation does not match spec for non-normal data
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-14 · updated 2026-10-15
- Weakness: CWE-400
Description
A flaw was found in GLib. GVariant deserialization is vulnerable to an exponential blowup issue where a crafted GVariant can cause excessive processing, leading to denial of service.
Affected products
- GNOME GLib: before 2.74.4 — fixed in 2.74.4
How to fix
Upgrade to a fixed version: GNOME GLib 2.74.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-32665
- https://bugzilla.redhat.com/show_bug.cgi?id=2211827
- https://gitlab.gnome.org/GNOME/glib/-/issues/2121
- https://lists.debian.org/debian-lts-announce/2023/09/msg00030.html
- https://security.gentoo.org/glsa/202311-18
- https://security.netapp.com/advisory/ntap-20240426-0006/
- https://access.redhat.com/security/cve/CVE-2023-32665
- https://bugzilla.redhat.com/show_bug.cgi?id=2211827
- https://gitlab.gnome.org/GNOME/glib/-/issues/2121
- https://lists.debian.org/debian-lts-announce/2023/09/msg00030.html
- https://security.gentoo.org/glsa/202311-18
- https://security.netapp.com/advisory/ntap-20240426-0006/
Get alerted when CVE-2023-32665 or the next vulnerability affects your stack