What’s Vulnerable › Vulnerabilities
CVE-2023-32675: Nonpayable default functions are sometimes payable in vyper
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-19 · updated 2026-06-17
- Weakness: CWE-670
Description
Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In contracts with more than one regular nonpayable function, it is possible to send funds to the default function, even if the default function is marked `nonpayable`. This applies to contracts compiled with vyper versions prior to 0.3.8. This issue was fixed by the removal of the global `calldatasize` check in commit `02339dfda`. Users are advised to upgrade to version 0.3.8. Users unable to upgrade should avoid use of nonpayable default functions.
Affected products
- vyperlang vyper: before 0.3.8 — fixed in 0.3.8
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/commit/02339dfda0f3caabad142060d511d10bfe93c520
- https://github.com/vyperlang/vyper/security/advisories/GHSA-vxmm-cwh2-q762
- https://github.com/vyperlang/vyper/commit/02339dfda0f3caabad142060d511d10bfe93c520
- https://github.com/vyperlang/vyper/security/advisories/GHSA-vxmm-cwh2-q762
Get alerted when CVE-2023-32675 or the next vulnerability affects your stack