What’s Vulnerable › Vulnerabilities
CVE-2023-32685: Clipboard based cross-site scripting (blocked with default CSP) in Kanboard
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Kanboard is project management software that focuses on the Kanban methodology. Due to improper handling of elements under the `contentEditable` element, maliciously crafted clipboard content can inject arbitrary HTML tags into the DOM. A low-privileged attacker with permission to attach a document on a vulnerable Kanboard instance can trick the victim into pasting malicious screenshot data and achieve cross-site scripting if CSP is improperly configured. This issue has been patched in version 1.2.29.
Affected products
- kanboard: before 1.2.29 — fixed in 1.2.29
How to fix
Upgrade to a fixed version: kanboard 1.2.29. Check the vendor advisory for mitigations.
References
- https://github.com/kanboard/kanboard/commit/26b6eebb78d4306e48b836a58f7c386251aa2bc7
- https://github.com/kanboard/kanboard/commit/c9c187206700030c43493b80fd599b4d096cb713
- https://github.com/kanboard/kanboard/security/advisories/GHSA-hjmw-gm82-r4gv
- https://github.com/kanboard/kanboard/commit/26b6eebb78d4306e48b836a58f7c386251aa2bc7
- https://github.com/kanboard/kanboard/commit/c9c187206700030c43493b80fd599b4d096cb713
- https://github.com/kanboard/kanboard/security/advisories/GHSA-hjmw-gm82-r4gv
Get alerted when CVE-2023-32685 or the next vulnerability affects your stack