What’s Vulnerable › Vulnerabilities
CVE-2023-32688: Invalid push request payload crashes Parse Server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-27 · updated 2026-06-17
- Weakness: CWE-20
Description
parse-server-push-adapter is the official Push Notification adapter for Parse Server. The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload. This issue has been patched in version 4.1.3.
Affected products
- parse-community parse-server-push-adapter: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: parse-community parse-server-push-adapter 4.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server-push-adapter/pull/217
- https://github.com/parse-community/parse-server-push-adapter/releases/tag/4.1.3
- https://github.com/parse-community/parse-server-push-adapter/security/advisories/GHSA-mxhg-rvwx-x993
- https://github.com/parse-community/parse-server-push-adapter/pull/217
- https://github.com/parse-community/parse-server-push-adapter/releases/tag/4.1.3
- https://github.com/parse-community/parse-server-push-adapter/security/advisories/GHSA-mxhg-rvwx-x993
Get alerted when CVE-2023-32688 or the next vulnerability affects your stack