What’s Vulnerable › Vulnerabilities
CVE-2023-32694: Non-constant time HMAC comparison in Adyen plugin in Saleor
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-25 · updated 2026-06-17
- Weakness: CWE-203
Description
Saleor Core is a composable, headless commerce API. Saleor's `validate_hmac_signature` function is vulnerable to timing attacks. Malicious users could abuse this vulnerability on Saleor deployments having the Adyen plugin enabled in order to determine the secret key and forge fake events, this could affect the database integrity such as marking an order as paid when it is not. This issue has been patched in versions 3.7.68, 3.8.40, 3.9.49, 3.10.36, 3.11.35, 3.12.25, and 3.13.16.
Affected products
- saleor: from 2.11.0 before 3.7.68; from 3.8.0 before 3.8.40; from 3.9.0 before 3.9.49; from 3.10.0 before 3.10.36; from 3.11.0 before 3.11.35; from 3.12.0 before 3.12.25 — fixed in 3.10.36, 3.11.35, 3.12.25, 3.13.16, 3.7.68, 3.8.40
How to fix
Upgrade to a fixed version: saleor 3.10.36, 3.11.35, 3.12.25, 3.13.16. Check the vendor advisory for mitigations.
References
- https://github.com/saleor/saleor/commit/1328274e1a3d04ab87d7daee90229ff47b3bc35e
- https://github.com/saleor/saleor/security/advisories/GHSA-3rqj-9v87-2x3f
- https://github.com/saleor/saleor/commit/1328274e1a3d04ab87d7daee90229ff47b3bc35e
- https://github.com/saleor/saleor/security/advisories/GHSA-3rqj-9v87-2x3f
Get alerted when CVE-2023-32694 or the next vulnerability affects your stack