What’s Vulnerable › Vulnerabilities
CVE-2023-32699: MeterSphere denial of service vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-30 · updated 2026-06-17
- Weakness: CWE-770
Description
MeterSphere is an open source continuous testing platform. Version 2.9.1 and prior are vulnerable to denial of service. The `checkUserPassword` method is used to check whether the password provided by the user matches the password saved in the database, and the `CodingUtil.md5` method is used to encrypt the original password with MD5 to ensure that the password will not be saved in plain text when it is stored. If a user submits a very long password when logging in, the system will be forced to execute the long password MD5 encryption process, causing the server CPU and memory to be exhausted, thereby causing a denial of service attack on the server. This issue is fixed in version 2.10.0-lts with a maximum password length.
Affected products
- metersphere: through 2.9.1
References
- https://github.com/metersphere/metersphere/commit/c59e381d368990214813085a1a4877c5ef865411
- https://github.com/metersphere/metersphere/security/advisories/GHSA-qffq-8gf8-mhq7
- https://github.com/metersphere/metersphere/commit/c59e381d368990214813085a1a4877c5ef865411
- https://github.com/metersphere/metersphere/security/advisories/GHSA-qffq-8gf8-mhq7
Get alerted when CVE-2023-32699 or the next vulnerability affects your stack