What’s Vulnerable › Vulnerabilities

CVE-2023-32700

Description

LuaTeX before 1.17.0 allows execution of arbitrary shell commands when compiling a TeX file obtained from an untrusted source. This occurs because luatex-core.lua lets the original io.popen be accessed. This also affects TeX Live before 2023 r66984 and MiKTeX before 23.5.

Affected products

How to fix

Upgrade to a fixed version: Luatex Project Luatex 1.16.2; Miktex 23.5; Tug Tex Live 2023. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-32700 or the next vulnerability affects your stack