What’s Vulnerable › Vulnerabilities
CVE-2023-32707: ‘edit_user’ Capability Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 79.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-01 · updated 2026-06-17
- Weakness: CWE-285
Description
In versions of Splunk Enterprise below 9.0.5, 8.2.11, and 8.1.14, and Splunk Cloud Platform below version 9.0.2303.100, a low-privileged user who holds a role that has the ‘edit_user’ capability assigned to it can escalate their privileges to that of the admin user by providing specially crafted web requests.
Affected products
- Splunk Enterprise: from 8.1.0 before 8.1.14; from 8.2.0 before 8.2.11; from 9.0.0 before 9.0.5 — fixed in 8.1.14, 8.2.11, 9.0.5
- Splunk Cloud Platform: before 9.0.2303.100 — fixed in 9.0.2303.100
How to fix
Upgrade to a fixed version: Splunk Enterprise 8.1.14, 8.2.11, 9.0.5; Splunk Cloud Platform 9.0.2303.100. Check the vendor advisory for mitigations.
References
- https://advisory.splunk.com/advisories/SVD-2023-0602
- https://research.splunk.com/application/39e1c326-67d7-4c0d-8584-8056354f6593/
- https://advisory.splunk.com/advisories/SVD-2023-0602
- https://research.splunk.com/application/39e1c326-67d7-4c0d-8584-8056354f6593/
Get alerted when CVE-2023-32707 or the next vulnerability affects your stack